CVE-2023-22045

NameCVE-2023-22045
DescriptionVulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Oracle Java SE: 8u371, 8u371-perf, 11.0.19, 17.0.7, 20.0.1; Oracle GraalVM Enterprise Edition: 20.3.10, 21.3.6, 22.3.2; Oracle GraalVM for JDK: 17.0.7 and 20.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK. Successful attacks of this vulnerability can result in unauthorized read access to a subset of Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK accessible data. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 3.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3571-1, DSA-5458-1, DSA-5478-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjdk-11 (PTS)buster11.0.16+8-1~deb10u1vulnerable
buster (security)11.0.20+8-1~deb10u1fixed
bullseye11.0.18+10-1~deb11u1vulnerable
bullseye (security)11.0.20+8-1~deb11u1fixed
sid11.0.21~4ea-1fixed
openjdk-17 (PTS)bullseye17.0.6+10-1~deb11u1vulnerable
bullseye (security)17.0.7+7-1~deb11u1vulnerable
bookworm17.0.7+7-1~deb12u1vulnerable
bookworm (security)17.0.8+7-1~deb12u1fixed
trixie, sid17.0.9~6ea-1fixed
openjdk-8 (PTS)sid8u382-ga-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-11sourcebuster11.0.20+8-1~deb10u1DLA-3571-1
openjdk-11sourcebullseye11.0.20+8-1~deb11u1DSA-5478-1
openjdk-11source(unstable)11.0.20+8-1
openjdk-17sourcebookworm17.0.8+7-1~deb12u1DSA-5458-1
openjdk-17source(unstable)17.0.8+7-1
openjdk-8source(unstable)8u382-ga-1

Search for package or bug name: Reporting problems