CVE-2023-25361

NameCVE-2023-25361
DescriptionA use-after-free vulnerability in WebCore::RenderLayer::setNextSibling in WebKitGTK before 2.36.8 allows attackers to execute code remotely.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3124-1, DSA-5240-1, DSA-5241-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1fixed
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.44.2-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.44.2-1~deb12u1fixed
sid, trixie2.44.2-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.38.6-1~deb11u1fixed
bookworm2.38.6-1fixed
sid, trixie2.44.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.38.0-1~deb10u1DLA-3124-1
webkit2gtksourcebullseye2.38.0-1~deb11u1DSA-5240-1
webkit2gtksource(unstable)2.38.0-1
wpewebkitsourcebullseye2.38.0-1~deb11u1DSA-5241-1
wpewebkitsource(unstable)2.38.0-1

Notes

https://bugs.webkit.org/show_bug.cgi?id=244249

Search for package or bug name: Reporting problems