DescriptionAn issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3749-1, DLA-3750-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-phpseclib (PTS)buster2.0.14-1vulnerable
buster (security)2.0.30-2~deb10u3fixed
bullseye (security), bullseye2.0.30-2+deb11u1vulnerable
bookworm, bookworm (security)2.0.42-1+deb12u1vulnerable
sid, trixie2.0.47-1fixed
php-phpseclib3 (PTS)bookworm, bookworm (security)3.0.19-1+deb12u2vulnerable
sid, trixie3.0.37-1fixed
phpseclib (PTS)buster1.0.14-1vulnerable
buster (security)1.0.19-3~deb10u3fixed
bullseye (security), bullseye1.0.19-3+deb11u1vulnerable
bookworm, bookworm (security)1.0.20-1+deb12u1vulnerable
sid, trixie1.0.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - phpseclib <no-dsa> (Minor issue; can be fixed via pu)
[bullseye] - phpseclib <no-dsa> (Minor issue; can be fixed via pu)
[bookworm] - php-phpseclib <no-dsa> (Minor issue; can be fixed via pu)
[bullseye] - php-phpseclib <no-dsa> (Minor issue; can be fixed via pu)
[bookworm] - php-phpseclib3 <no-dsa> (Minor issue; can be fixed via pu)

Search for package or bug name: Reporting problems