CVE-2024-3044

NameCVE-2024-3044
DescriptionUnchecked script execution in Graphic on-click binding in affected LibreOffice versions allows an attacker to create a document which without prompt will execute scripts built-into LibreOffice on clicking a graphic. Such scripts were previously deemed trusted but are now deemed untrusted.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5690-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)buster1:6.1.5-3+deb10u7vulnerable
buster (security)1:6.1.5-3+deb10u11vulnerable
bullseye1:7.0.4-4+deb11u8vulnerable
bullseye (security)1:7.0.4-4+deb11u9fixed
bookworm4:7.4.7-1+deb12u1vulnerable
bookworm (security)4:7.4.7-1+deb12u2fixed
trixie, sid4:24.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesourcebullseye1:7.0.4-4+deb11u9DSA-5690-1
libreofficesourcebookworm4:7.4.7-1+deb12u2DSA-5690-1
libreofficesource(unstable)4:24.2.3~rc1-2

Notes

https://www.libreoffice.org/about-us/security/advisories/cve-2024-3044/
https://git.libreoffice.org/core/+/8b2402b16df185119c91222b33ff1b8d55e0afe4%5E%21

Search for package or bug name: Reporting problems