CVE-2024-37535

NameCVE-2024-37535
DescriptionGNOME VTE before 0.76.3 allows an attacker to cause a denial of service (memory consumption) via a window resize escape sequence, a related issue to CVE-2000-0476.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vte (PTS)buster, bookworm, bullseye1:0.28.2-6vulnerable
sid, trixie1:0.28.2-6.1vulnerable
vte2.91 (PTS)buster0.54.2-2vulnerable
bullseye0.62.3-1vulnerable
bookworm0.70.6-2~deb12u1vulnerable
sid, trixie0.75.92-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vtesource(unstable)(unfixed)
vte2.91sourceexperimental0.76.3-1
vte2.91source(unstable)(unfixed)

Notes

[bookworm] - vte <no-dsa> (Minor issue)
[bullseye] - vte <no-dsa> (Minor issue)
[buster] - vte <postponed> (Minor issue)
[bookworm] - vte2.91 <no-dsa> (Minor issue)
[bullseye] - vte2.91 <no-dsa> (Minor issue)
[buster] - vte2.91 <postponed> (Minor issue)
https://gitlab.gnome.org/GNOME/vte/-/issues/2786
https://www.openwall.com/lists/oss-security/2024/06/09/1
https://gitlab.gnome.org/GNOME/vte/-/commit/fd5511f24b7269195a7083f409244e9787c705dc (master)
https://gitlab.gnome.org/GNOME/vte/-/commit/1803ba866053a3d7840892b9d31fe2944a183eda (master)
https://gitlab.gnome.org/GNOME/vte/-/commit/036bc3ddcbb56f05c6ca76712a53b89dee1369e2 (0.76.3)
https://gitlab.gnome.org/GNOME/vte/-/commit/c313849c2e5133802e21b13fa0b141b360171d39 (0.76.3)

Search for package or bug name: Reporting problems