CVE-2005-3178

NameCVE-2005-3178
DescriptionBuffer overflow in xloadimage 4.1 and earlier, and xli, might allow user-assisted attackers to execute arbitrary code via a long title name in a NIFF file, which triggers the overflow during (1) zoom, (2) reduce, or (3) rotate operations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-858-1, DSA-859-1
NVD severitymedium (attack range: remote)
Debian Bugs332524

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xli (PTS)wheezy, jessie, stretch1.17.0+20061110-4fixed
buster, sid1.17.0+20061110-5fixed
xloadimage (PTS)wheezy4.1-19fixed
jessie4.1-23fixed
buster, sid, stretch4.1-24fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xlisource(unstable)1.17.0-20medium
xlisourcesarge1.17.0-18sarge1mediumDSA-859-1
xlisourcewoody1.17.0-11woody2mediumDSA-859-1
xloadimagesource(unstable)4.1-15medium332524
xloadimagesourcesarge4.1-14.3mediumDSA-858-1
xloadimagesourcewoody4.1-10woody2mediumDSA-858-1332524

Notes

xli couldn't load the provided test images when I checked?

Search for package or bug name: Reporting problems