CVE-2005-3193

NameCVE-2005-3193
DescriptionHeap-based buffer overflow in the JPXStream::readCodestream function in the JPX stream parsing code (JPXStream.c) for xpdf 3.01 and earlier, as used in products such as (1) Poppler, (2) teTeX, (3) KDE kpdf, (4) CUPS, and (5) libextractor allows user-assisted attackers to cause a denial of service (heap corruption) and possibly execute arbitrary code via a crafted PDF file with large size values that cause insufficient memory to be allocated.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-931-1, DSA-932-1, DSA-936-1, DSA-937-1, DSA-950-1, DSA-961-1, DSA-979-1, DSA-982-1, DSA-984-1, DTSA-28-1
Debian Bugs342281, 342286, 342287, 342288, 342292, 342337

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)buster, buster (security)2.2.10-6+deb10u6fixed
bullseye (security), bullseye2.3.3op2-3+deb11u2fixed
bookworm, sid2.4.2-1fixed
libextractor (PTS)buster1:1.8-2+deb10u1fixed
bullseye1:1.11-2fixed
bookworm, sid1:1.11-6fixed
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u1fixed
bullseye20.09.0-3.1fixed
bullseye (security)20.09.0-3.1+deb11u1fixed
bookworm, sid22.08.0-2.1fixed
xpdf (PTS)buster3.04-13fixed
bullseye3.04+git20210103-3fixed
bookworm, sid3.04+git20220601-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)1.1.23-13unimportant
cupsyssourcewoody1.1.14-5woody14DSA-950-1
cupsyssourcesarge(not affected)DSA-950-1
cupsyssource(unstable)1.1.23-13unimportant
gpdfsourcesarge2.8.2-1.2sarge4DSA-982-1
gpdfsourceetch2.10.0-1+etch1DTSA-28-1
gpdfsource(unstable)2.10.0-1medium342286
kdegraphicssourcesarge4:3.3.2-2sarge3DSA-932-1
kdegraphicssource(unstable)4:3.4.3-4medium342287
kofficesource(unstable)(not affected)
libextractorsourcesarge0.4.2-2sarge2DSA-936-1
libextractorsource(unstable)0.5.8-1medium
pdfkit.frameworksourcesarge0.8-2sarge3DSA-979-1
pdfkit.frameworksource(unstable)0.8-4
pdftohtmlsource(unstable)(not affected)
popplersource(unstable)0.4.2-1.1medium342288
tetex-binsourcewoody1.0.7+20011202-7.7DSA-937-1
tetex-binsourcesarge2.0.2-30sarge4DSA-937-1
tetex-binsource(unstable)3.0-11medium342292
xpdfsourcewoody1.00-3.8DSA-931-1
xpdfsourcesarge3.00-13.6DSA-984-1
xpdfsource(unstable)3.01-3medium342281, 342337

Notes

- pdftohtml <not-affected> (Vulnerable xpdf code not contained)
Previous kdegraphics fix was incomplete
- koffice <not-affected> (Vulnerable xpdf code not contained)

Search for package or bug name: Reporting problems