CVE-2008-4796

NameCVE-2008-4796
DescriptionThe _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1691-1, DSA-1871-1, DSA-1871-2
NVD severityhigh (attack range: remote)
Debian Bugs504168, 504169, 504170, 504171, 504172, 504173, 504234, 504235
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ampache (PTS)squeeze3.5.4-9fixed
jessie3.6-rzb2752+dfsg-5fixed
stretch, sid3.6-rzb2752+dfsg-6fixed
libphp-snoopy (PTS)squeeze, wheezy1.2.4-2fixed
wheezy (security)2.0.0-1~deb7u1fixed
stretch, sid, jessie2.0.0-1fixed
magpierss (PTS)squeeze0.72-8+squeeze2fixed
stretch, sid, jessie, wheezy0.72-10fixed
mahara (PTS)squeeze (security)1.2.6-2+squeeze6fixed
moodle (PTS)squeeze1.9.9.dfsg2-2.1+squeeze4fixed
squeeze (security)1.9.9.dfsg2-2.1+squeeze3fixed
sid2.7.9+dfsg-1fixed
wordpress (PTS)squeeze, squeeze (security)3.6.1+dfsg-1~deb6u4fixed
squeeze (lts)3.6.1+dfsg-1~deb6u7fixed
wheezy3.6.1+dfsg-1~deb7u5fixed
wheezy (security)3.6.1+dfsg-1~deb7u6fixed
jessie4.1+dfsg-1+deb8u1fixed
jessie (security)4.1+dfsg-1+deb8u4fixed
stretch, sid4.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ampachesource(unstable)3.4.1-2high504169
gforge-plugin-scmcvssource(unstable)(unfixed)high
gforge-plugin-scmcvssourceetch(not affected)
libphp-snoopysource(unstable)1.2.4-1medium504168
magpiersssource(unstable)(not affected)
maharasource(unstable)1.0.5-2high504170
maharasourcelenny1.0.4-3high
mediamatesource(unstable)0.9.3.6-5unimportant504172
moodlesource(unstable)1.8.2-2high504235
moodlesourceetch1.6.3-2+etch1highDSA-1691-1
opendbsource(unstable)(unfixed)unimportant504173
pixelpostsource(unstable)1.7.1-5high504171
wordpresssource(unstable)2.5.1-9high504234
wordpresssourceetch2.0.10-1etch5highDSA-1871-2
wordpresssourcelenny2.5.1-11+lenny1highDSA-1871-1

Notes

mediamate does not use snoopy in https requests
[etch] - gforge-plugin-scmcvs <not-affected> (Snoopy function not used on URLs that come from user input)
- magpierss <not-affected> (Fixed in all supported distributions)

Search for package or bug name: Reporting problems