CVE-2015-3165

NameCVE-2015-3165
DescriptionDouble free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-227-1, DSA-3269-1, DSA-3270-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.24lts2-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie (security), jessie9.4.15-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.4source(unstable)(unfixed)medium
postgresql-8.4sourcesqueeze8.4.22lts2-0+deb6u2mediumDLA-227-1
postgresql-8.4sourcewheezy(not affected)
postgresql-9.1source(unstable)(unfixed)medium
postgresql-9.1sourcejessie9.1.16-0+deb8u1mediumDSA-3269-1
postgresql-9.1sourcewheezy9.1.16-0+deb7u1mediumDSA-3269-1
postgresql-9.4source(unstable)9.4.2-1medium
postgresql-9.4sourcejessie9.4.2-0+deb8u1mediumDSA-3270-1

Notes

Since 9.1.1-2 src:postgresql-9.1 builds only postgresql-plperl-9.1, source-wise fixed
[wheezy] - postgresql-8.4 <not-affected> (postgresql-8.4 in wheezy only provides PL/Perl; EOL upstream)

Search for package or bug name: Reporting problems