CVE-2016-0766

NameCVE-2016-0766
DescriptionPostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x before 9.5.1 does not properly restrict access to unspecified custom configuration settings (GUCS) for PL/Java, which allows attackers to gain privileges via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3475-1, DSA-3476-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-9.1 (PTS)wheezy9.1.21-0+deb7u1fixed
wheezy (security)9.1.24lts2-0+deb7u1fixed
jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie9.4.12-0+deb8u1fixed
jessie (security)9.4.13-0+deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-9.1source(unstable)(unfixed)high
postgresql-9.1sourcejessie(not affected)
postgresql-9.1sourcewheezy9.1.20-0+deb7u1highDSA-3475-1
postgresql-9.4source(unstable)(unfixed)high
postgresql-9.4sourcejessie9.4.6-0+deb8u1highDSA-3476-1
postgresql-9.5source(unstable)9.5.1high

Notes

[jessie] - postgresql-9.1 <not-affected> (postgresql-9.1 in jessie only provides PL/Perl)

Search for package or bug name: Reporting problems