CVE-2017-5837

NameCVE-2017-5837
DescriptionThe gst_riff_create_audio_caps function in gst-libs/gst/riff/riff-media.c in gst-plugins-base in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (floating point exception and crash) via a crafted video file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2126-1, DLA-827-1, DSA-3819-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-base1.0 (PTS)stretch (security), stretch1.10.4-1+deb9u1fixed
buster1.14.4-2fixed
bullseye, sid1.18.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-base0.10sourcewheezy0.10.36-1.1+deb7u2DLA-827-1
gst-plugins-base0.10sourcejessie0.10.36-2+deb8u2DLA-2126-1
gst-plugins-base0.10source(unstable)(unfixed)low
gst-plugins-base1.0sourcejessie1.4.4-2+deb8u1DSA-3819-1
gst-plugins-base1.0source(unstable)1.10.3-1low

Notes

https://www.openwall.com/lists/oss-security/2017/02/01/7
https://bugzilla.gnome.org/show_bug.cgi?id=777262

Search for package or bug name: Reporting problems