|Description||A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)|
Vulnerable and fixed packages
The table below lists information on source packages.
|postgresql-9.6 (PTS)||stretch (security), stretch||9.6.17-0+deb9u1||fixed|
The information below is based on the following data on fixed versions.
[jessie] - postgresql-9.1 <no-dsa> (package only serves as a means for upgrading to Stretch)
Fixed in 9.3.24, 9.4.19, 9.5.14, 9.6.10, 10.5