CVE-2018-10915

NameCVE-2018-10915
DescriptionA vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1464-1, DSA-4269-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-10 (PTS)buster, sid10.5-1fixed
postgresql-9.1 (PTS)jessie9.1.22-0+deb8u1vulnerable
jessie (security)9.1.16-0+deb8u1vulnerable
postgresql-9.4 (PTS)jessie9.4.18-0+deb8u1vulnerable
jessie (security)9.4.19-0+deb8u1fixed
postgresql-9.6 (PTS)stretch9.6.9-0+deb9u1vulnerable
stretch (security)9.6.10-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-10source(unstable)10.5-1medium
postgresql-9.1source(unstable)(unfixed)medium
postgresql-9.4source(unstable)(unfixed)medium
postgresql-9.4sourcejessie9.4.19-0+deb8u1mediumDLA-1464-1
postgresql-9.5source(unstable)(unfixed)medium
postgresql-9.6source(unstable)(unfixed)medium
postgresql-9.6sourcestretch9.6.10-0+deb9u1mediumDSA-4269-1

Notes

[jessie] - postgresql-9.1 <no-dsa> (package only serves as a means for upgrading to Stretch)
Fixed in 9.3.24, 9.4.19, 9.5.14, 9.6.10, 10.5
https://www.postgresql.org/about/news/1878/

Search for package or bug name: Reporting problems