CVE-2018-16850

NameCVE-2018-16850
Descriptionpostgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-10 (PTS)sid10.5-1vulnerable
postgresql-11 (PTS)buster, sid11.1-1fixed
postgresql-9.1 (PTS)jessie9.1.22-0+deb8u1fixed
jessie (security)9.1.16-0+deb8u1fixed
postgresql-9.4 (PTS)jessie9.4.18-0+deb8u1fixed
jessie (security)9.4.19-0+deb8u1fixed
postgresql-9.6 (PTS)stretch (security), stretch9.6.10-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-10source(unstable)(unfixed)
postgresql-11source(unstable)11.1-1
postgresql-9.1source(unstable)(not affected)
postgresql-9.4source(unstable)(not affected)
postgresql-9.6source(unstable)(not affected)

Notes

- postgresql-9.6 <not-affected> (Only affects 11.x and 10.x)
- postgresql-9.4 <not-affected> (Only affects 11.x and 10.x)
- postgresql-9.1 <not-affected> (Only affects 11.x and 10.x)
https://www.postgresql.org/about/news/1905/
Fixed in 11.1, 10.6

Search for package or bug name: Reporting problems