Descriptionpostgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-9.1source(unstable)(not affected)
postgresql-9.4source(unstable)(not affected)
postgresql-9.6source(unstable)(not affected)


- postgresql-9.6 <not-affected> (Only affects 11.x and 10.x)
- postgresql-9.4 <not-affected> (Only affects 11.x and 10.x)
- postgresql-9.1 <not-affected> (Only affects 11.x and 10.x)
Fixed in 11.1, 10.6

Search for package or bug name: Reporting problems