CVE-2018-20021

NameCVE-2018-20021
DescriptionLibVNC before commit c3115350eb8bb635d0fdb4dbbb0d0541f38ed19c contains a CWE-835: Infinite loop vulnerability in VNC client code. Vulnerability allows attacker to consume excessive amount of resources like CPU and RAM
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1617-1
NVD severityhigh (attack range: remote)
Debian Bugs916941

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)jessie0.9.9+dfsg2-6.1+deb8u3vulnerable
jessie (security)0.9.9+dfsg2-6.1+deb8u4fixed
stretch (security), stretch0.9.11+dfsg-1+deb9u1vulnerable
buster, sid0.9.11+dfsg-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversource(unstable)0.9.11+dfsg-1.2high916941
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u4highDLA-1617-1

Notes

https://github.com/LibVNC/libvncserver/issues/251
https://github.com/LibVNC/libvncserver/commit/c3115350eb8bb635d0fdb4dbbb0d0541f38ed19c
https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-031-libvnc-infinite-loop/

Search for package or bug name: Reporting problems