CVE-2019-5010

NameCVE-2019-5010
DescriptionNULL pointer dereference using a specially crafted X509 certificate
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1663-1
Debian Bugs921040, 921063, 921064

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie2.7.9-2+deb8u1vulnerable
jessie (security)2.7.9-2+deb8u2vulnerable
stretch (security), stretch2.7.13-2+deb9u3vulnerable
buster, sid2.7.16-2fixed
python3.4 (PTS)jessie3.4.2-1vulnerable
jessie (security)3.4.2-1+deb8u2fixed
python3.5 (PTS)stretch (security), stretch3.5.3-1+deb9u1vulnerable
python3.7 (PTS)buster, sid3.7.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.7source(unstable)2.7.15-6921040
python3.4source(unstable)(unfixed)
python3.4sourcejessie3.4.2-1+deb8u2DLA-1663-1
python3.5source(unstable)(unfixed)
python3.6source(unstable)(unfixed)921063
python3.7source(unstable)3.7.2-2921064

Notes

[stretch] - python3.5 <postponed> (Minor issue, can be fixed along in a future DSA)
[stretch] - python2.7 <postponed> (Minor issue, can be fixed along in a future DSA)
[jessie] - python2.7 <postponed> (Minor issue, can be fixed along in a future DSA)
https://bugs.python.org/issue35746
https://github.com/python/cpython/pull/11569
https://github.com/python/cpython/commit/be5de958e9052e322b0087c6dba81cdad0c3e031 (3.7.x)
https://github.com/python/cpython/commit/216a4d83c3b72f4fdcd81b588dc3f42cc461739a (3.6.x)
https://github.com/python/cpython/commit/06b15424b0dcacb1c551b2a36e739fffa8d0c595 (2.7.x)

Search for package or bug name: Reporting problems