CVE-2019-9636

NameCVE-2019-9636
DescriptionPython 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1834-1, DLA-1835-1
NVD severitymedium
Debian Bugs924072, 924073

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie2.7.9-2+deb8u1vulnerable
jessie (security)2.7.9-2+deb8u5fixed
stretch (security), stretch2.7.13-2+deb9u3vulnerable
buster2.7.16-2fixed
bullseye, sid2.7.17-1fixed
python3.4 (PTS)jessie3.4.2-1vulnerable
jessie (security)3.4.2-1+deb8u7fixed
python3.5 (PTS)stretch (security), stretch3.5.3-1+deb9u1vulnerable
python3.7 (PTS)buster3.7.3-2fixed
bullseye, sid3.7.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.7source(unstable)2.7.16-2924073
python2.7sourcejessie2.7.9-2+deb8u3DLA-1834-1
python3.4source(unstable)(unfixed)
python3.4sourcejessie3.4.2-1+deb8u3DLA-1835-1
python3.5source(unstable)(unfixed)
python3.6source(unstable)(unfixed)
python3.7source(unstable)3.7.3~rc1-1924072

Notes

[stretch] - python2.7 <no-dsa> (Minor issue)
https://bugs.python.org/issue36216
https://github.com/python/cpython/pull/12201
https://python-security.readthedocs.io/vuln/urlsplit-nfkc-normalization.html
https://github.com/python/cpython/commit/daad2c482c91de32d8305abbccc76a5de8b3a8be (3.7.x)
https://github.com/python/cpython/commit/e37ef41289b77e0f0bb9a6aedb0360664c55bdd5 (2.7.x)
Regression fix: https://bugs.python.org/issue36742
When fixing this issue make sure to not open CVE-2019-10160.

Search for package or bug name: Reporting problems