CVE-2019-9740

NameCVE-2019-9740
DescriptionAn issue was discovered in urllib2 in Python 2.x through 2.7.16 and urllib in Python 3.x through 3.7.3. CRLF injection is possible if the attacker controls a url parameter, as demonstrated by the first argument to urllib.request.urlopen with \r\n (specifically in the query string after a ? character) followed by an HTTP header or a Redis command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1834-1, DLA-1835-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie2.7.9-2+deb8u1vulnerable
jessie (security)2.7.9-2+deb8u3fixed
stretch (security), stretch2.7.13-2+deb9u3vulnerable
bullseye, buster2.7.16-2vulnerable
sid2.7.16-3fixed
python3.4 (PTS)jessie3.4.2-1vulnerable
jessie (security)3.4.2-1+deb8u5fixed
python3.5 (PTS)stretch (security), stretch3.5.3-1+deb9u1vulnerable
python3.7 (PTS)bullseye, buster3.7.3-2vulnerable
sid3.7.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.7source(unstable)2.7.16-3medium
python2.7sourcejessie2.7.9-2+deb8u3mediumDLA-1834-1
python3.4source(unstable)(unfixed)medium
python3.4sourcejessie3.4.2-1+deb8u3mediumDLA-1835-1
python3.5source(unstable)(unfixed)medium
python3.6source(unstable)(unfixed)medium
python3.7source(unstable)3.7.4~rc2-2medium

Notes

[buster] - python3.7 <no-dsa> (Minor issue)
[buster] - python2.7 <no-dsa> (Minor issue)
[stretch] - python2.7 <no-dsa> (Minor issue)
https://bugs.python.org/issue36276
https://bugs.python.org/issue30458

Search for package or bug name: Reporting problems