CVE-2020-11022

NameCVE-2020-11022
DescriptionIn jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4693-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)stretch (security), stretch7.52-2+deb9u11fixed
jquery (PTS)stretch3.1.1-2+deb9u1vulnerable
buster3.3.1~dfsg-3vulnerable
node-jquery (PTS)buster2.2.4+dfsg-4vulnerable
bullseye, sid3.5.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7sourcejessie(not affected)
drupal7sourcestretch7.52-2+deb9u10DSA-4693-1
drupal7source(unstable)(unfixed)
jquerysourcejessie(not affected)
jquerysource(unstable)(unfixed)
node-jquerysource(unstable)3.5.0+dfsg-2

Notes

[buster] - jquery <no-dsa> (Minor issue)
[stretch] - jquery <no-dsa> (Minor issue)
[jessie] - jquery <not-affected> (Vulnerable code note present)
[buster] - node-jquery <no-dsa> (Minor issue)
[jessie] - drupal7 <not-affected> (Vulnerable code not embedded)
https://github.com/jquery/jquery/security/advisories/GHSA-gxr4-xjj5-5px2
https://github.com/jquery/jquery/commit/1d61fd9407e6fbe82fe55cb0b938307aa0791f77
https://www.drupal.org/sa-core-2020-002

Search for package or bug name: Reporting problems