CVE-2020-11023

NameCVE-2020-11023
DescriptionIn jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4693-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)jessie7.32-1+deb8u12vulnerable
jessie (security)7.32-1+deb8u17vulnerable
stretch7.52-2+deb9u9vulnerable
stretch (security)7.52-2+deb9u10fixed
jquery (PTS)jessie1.7.2+dfsg-3.2fixed
jessie (security)1.7.2+dfsg-3.2+deb8u7fixed
stretch3.1.1-2+deb9u1vulnerable
buster3.3.1~dfsg-3vulnerable
node-jquery (PTS)buster2.2.4+dfsg-4vulnerable
bullseye, sid3.5.1+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7source(unstable)(unfixed)
drupal7sourcestretch7.52-2+deb9u10DSA-4693-1
jquerysource(unstable)(unfixed)
jquerysourcejessie(not affected)
node-jquerysource(unstable)3.5.0+dfsg-2

Notes

[jessie] - jquery <not-affected> (Vulnerable code note present)
https://github.com/jquery/jquery/security/advisories/GHSA-jpcq-cgw6-v4j6
https://www.drupal.org/sa-core-2020-002

Search for package or bug name: Reporting problems