Descriptionphpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-phpseclib (PTS)buster2.0.14-1vulnerable
bookworm, sid2.0.37-1fixed
php-phpseclib3 (PTS)bookworm, sid3.0.14-1fixed
phpseclib (PTS)buster1.0.14-1vulnerable
bookworm, sid1.0.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-phpseclibsourcestretch(not affected)
phpseclibsourcestretch(not affected)


[stretch] - phpseclib <not-affected> (Only affects 3.x branch)
[stretch] - php-phpseclib <not-affected> (Only affects 3.x branch)
Introduced by: (v3.0 / RSA::SIGNATURE_RELAXED_PKCS1)
According to upstream, 1.x and 2.x are not vulnerable, the fix on these branches only backports more exhaustive PKCS#1 v1.5 support (functional change)
According to upstream, 1.x and 2.x have the problem described as "incompatibility issue in phpseclib v1, v2, v3 (strict mode)'s RSA PKCS#1 v1.5
signature verification suffering from rejecting valid signatures whose encoded message uses implicit hash algorithm's NULL parameter." but
this is not considered as a security problem.

Search for package or bug name: Reporting problems