CVE-2021-30130

NameCVE-2021-30130
Descriptionphpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-phpseclib (PTS)stretch2.0.4-1fixed
buster2.0.14-1vulnerable
bullseye, sid2.0.30-2fixed
php-phpseclib3 (PTS)sid3.0.9-1fixed
phpseclib (PTS)stretch1.0.5-1fixed
buster1.0.14-1vulnerable
bullseye, sid1.0.19-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-phpseclibsourcestretch(not affected)
php-phpseclibsource(unstable)2.0.30-2
php-phpseclib3source(unstable)3.0.7-1
phpseclibsourcestretch(not affected)
phpseclibsource(unstable)1.0.19-3

Notes

[stretch] - phpseclib <not-affected> (Only affects 3.x branch)
[stretch] - php-phpseclib <not-affected> (Only affects 3.x branch)
https://github.com/phpseclib/phpseclib/pull/1635#issuecomment-826994890
Introduced by: https://github.com/phpseclib/phpseclib/commit/cc32cd2e95b18a0c0118bbf1928327675c9e64a9 (v3.0 / RSA::SIGNATURE_RELAXED_PKCS1)
According to upstream, 1.x and 2.x are not vulnerable, the fix on these branches only backports more exhaustive PKCS#1 v1.5 support (functional change)
According to upstream, 1.x and 2.x have the problem described as "incompatibility issue in phpseclib v1, v2, v3 (strict mode)'s RSA PKCS#1 v1.5
signature verification suffering from rejecting valid signatures whose encoded message uses implicit hash algorithm's NULL parameter." but
this is not considered as a security problem.

Search for package or bug name: Reporting problems