CVE-2022-31607

NameCVE-2022-31607
DescriptionNVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer (nvidia.ko), where a local user with basic capabilities can cause improper input validation, which may lead to denial of service, escalation of privileges, data tampering, and limited information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1016614, 1016615, 1016616, 1016617, 1016618, 1016619, 1016620, 1016621

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)buster/non-free418.226.00-3vulnerable
bullseye/non-free470.141.03-1~deb11u1fixed
bookworm/non-free, sid/non-free510.85.02-6fixed
nvidia-graphics-drivers-legacy-340xx (PTS)buster/non-free340.108-3~deb10u1vulnerable
sid/non-free340.108-16vulnerable
nvidia-graphics-drivers-legacy-390xx (PTS)buster/non-free390.154-1~deb10u1fixed
bullseye/non-free390.154-1~deb11u1fixed
bookworm/non-free, sid/non-free390.154-2fixed
nvidia-graphics-drivers-tesla-418 (PTS)bullseye/non-free418.226.00-6~deb11u1vulnerable
sid/non-free418.226.00-8vulnerable
nvidia-graphics-drivers-tesla-450 (PTS)bullseye/non-free450.203.03-1~deb11u1fixed
bookworm/non-free, sid/non-free450.203.03-2fixed
nvidia-graphics-drivers-tesla-460 (PTS)bullseye/non-free460.106.00-6~deb11u1fixed
bookworm/non-free, sid/non-free460.106.00-8fixed
nvidia-graphics-drivers-tesla-470 (PTS)bullseye/non-free470.141.03-1~deb11u1fixed
bookworm/non-free, sid/non-free470.141.03-3fixed
nvidia-graphics-drivers-tesla-510 (PTS)bookworm/non-free, sid/non-free510.85.02-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssourcebullseye470.141.03-1~deb11u1
nvidia-graphics-driverssource(unstable)470.141.03-11016614
nvidia-graphics-drivers-legacy-340xxsource(unstable)(unfixed)1016615
nvidia-graphics-drivers-legacy-390xxsourcebuster390.154-1~deb10u1
nvidia-graphics-drivers-legacy-390xxsourcebullseye390.154-1~deb11u1
nvidia-graphics-drivers-legacy-390xxsource(unstable)390.154-11016616
nvidia-graphics-drivers-tesla-418source(unstable)(unfixed)1016617
nvidia-graphics-drivers-tesla-450sourcebullseye450.203.03-1~deb11u1
nvidia-graphics-drivers-tesla-450source(unstable)450.203.03-11016618
nvidia-graphics-drivers-tesla-460source(unstable)460.106.00-31016619
nvidia-graphics-drivers-tesla-470sourcebullseye470.141.03-1~deb11u1
nvidia-graphics-drivers-tesla-470source(unstable)470.141.03-11016620
nvidia-graphics-drivers-tesla-510source(unstable)510.85.02-11016621

Notes

[buster] - nvidia-graphics-drivers <ignored> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-340xx <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-418 <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-460 <no-dsa> (Non-free not supported)
460.106.00-3 turned the package into a metapackage to aid switching to nvidia-graphics-drivers-tesla-470

Search for package or bug name: Reporting problems