CVE-2022-31631

NameCVE-2022-31631
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3345-1, DSA-5363-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.4 (PTS)bullseye (security), bullseye7.4.33-1+deb11u5fixed
php8.2 (PTS)bookworm, bookworm (security)8.2.20-1~deb12u1fixed
sid, trixie8.2.21-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.3sourcebuster7.3.31-1~deb10u3DLA-3345-1
php7.3source(unstable)(unfixed)
php7.4sourcebullseye7.4.33-1+deb11u3DSA-5363-1
php7.4source(unstable)(unfixed)
php8.1source(unstable)(unfixed)
php8.2source(unstable)8.2.1-1

Notes

Fixed in 8.0.27, 8.1.14, 8.2.1
PHP Bug: https://bugs.php.net/bug.php?id=81740
Fixed by: https://github.com/php/php-src/commit/921b6813da3237a83e908998483f46ae3d8bacba (php-8.0.27)
Improvement: https://github.com/php/php-src/commit/a6a80eefe0413c91acd922bc58590a4db7979af0

Search for package or bug name: Reporting problems