CVE-2023-25516

NameCVE-2023-25516
DescriptionNVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer, where an unprivileged user can cause an integer overflow, which may lead to information disclosure and denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1039678, 1039679, 1039680, 1039681, 1039682, 1039683, 1039684, 1039685, 1039686

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)buster/non-free418.226.00-3vulnerable
bullseye/non-free470.223.02-1fixed
bookworm/non-free-firmware525.147.05-4~deb12u1fixed
trixie/non-free-firmware535.161.08-2fixed
sid/non-free-firmware535.183.01-1fixed
nvidia-graphics-drivers-legacy-340xx (PTS)buster/non-free340.108-3~deb10u1vulnerable
sid/non-free340.108-21vulnerable
nvidia-graphics-drivers-legacy-390xx (PTS)buster/non-free390.154-1~deb10u1vulnerable
buster/non-free (security)390.157-1~deb10u1vulnerable
bullseye/non-free390.157-1~deb11u1vulnerable
sid/non-free390.157-7vulnerable
nvidia-graphics-drivers-tesla (PTS)bookworm/non-free-firmware525.147.05-4~deb12u1fixed
sid/non-free-firmware, trixie/non-free-firmware525.147.05-10fixed
nvidia-graphics-drivers-tesla-418 (PTS)bullseye/non-free418.226.00-6~deb11u1vulnerable
sid/non-free418.226.00-14vulnerable
nvidia-graphics-drivers-tesla-450 (PTS)bullseye/non-free450.248.02-1~deb11u1fixed
sid/non-free450.248.02-5fixed
nvidia-graphics-drivers-tesla-460 (PTS)bullseye/non-free460.106.00-6~deb11u1fixed
sid/non-free460.106.00-15fixed
nvidia-graphics-drivers-tesla-470 (PTS)bullseye/non-free470.223.02-2~deb11u1fixed
bookworm/non-free470.223.02-2~deb12u1fixed
sid/non-free, trixie/non-free470.256.02-1fixed
nvidia-open-gpu-kernel-modules (PTS)bookworm/contrib525.147.05-1~deb12u1fixed
trixie/contrib, sid/contrib535.161.08-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssourcebullseye470.199.02-1
nvidia-graphics-driverssourcebookworm525.125.06-1~deb12u1
nvidia-graphics-driverssource(unstable)525.125.06-11039678
nvidia-graphics-drivers-legacy-340xxsource(unstable)(unfixed)1039679
nvidia-graphics-drivers-legacy-390xxsource(unstable)(unfixed)1039680
nvidia-graphics-drivers-teslasourcebookworm525.125.06-1~deb12u1
nvidia-graphics-drivers-teslasource(unstable)525.125.06-11039685
nvidia-graphics-drivers-tesla-418source(unstable)(unfixed)1039681
nvidia-graphics-drivers-tesla-450sourcebullseye450.248.02-1~deb11u1
nvidia-graphics-drivers-tesla-450source(unstable)450.248.02-11039682
nvidia-graphics-drivers-tesla-460source(unstable)460.106.00-31039683
nvidia-graphics-drivers-tesla-470sourcebullseye470.199.02-1~deb11u1
nvidia-graphics-drivers-tesla-470sourcebookworm470.199.02-1~deb12u1
nvidia-graphics-drivers-tesla-470source(unstable)470.199.02-11039684
nvidia-open-gpu-kernel-modulessourcebookworm525.125.06-1~deb12u1
nvidia-open-gpu-kernel-modulessource(unstable)525.125.06-11039686

Notes

[bullseye] - nvidia-graphics-drivers-tesla-460 <no-dsa> (Non-free not supported)
460.106.00-3 turned the package into a metapackage to aid switching to nvidia-graphics-drivers-tesla-470
[bullseye] - nvidia-graphics-drivers-tesla-418 <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-legacy-390xx <no-dsa> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-390xx <no-dsa> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-340xx <ignored> (Non-free not supported, no updates provided by Nvidia anymore)
[buster] - nvidia-graphics-drivers <postponed> (Minor issue, revisit when/if fixed upstream)
https://nvidia.custhelp.com/app/answers/detail/a_id/5468

Search for package or bug name: Reporting problems