CVE-2023-31022

NameCVE-2023-31022
DescriptionNVIDIA GPU Display Driver for Windows and Linux contains a vulnerability in the kernel mode layer, where a NULL-pointer dereference may lead to denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1055136, 1055137, 1055138, 1055139, 1055140, 1055141, 1055142, 1055143, 1055144

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)buster/non-free418.226.00-3vulnerable
bullseye/non-free470.223.02-1fixed
bookworm/non-free-firmware525.147.05-4~deb12u1fixed
trixie/non-free-firmware, sid/non-free-firmware535.161.08-2fixed
nvidia-graphics-drivers-legacy-340xx (PTS)buster/non-free340.108-3~deb10u1vulnerable
sid/non-free340.108-21vulnerable
nvidia-graphics-drivers-legacy-390xx (PTS)buster/non-free390.154-1~deb10u1vulnerable
buster/non-free (security)390.157-1~deb10u1vulnerable
bullseye/non-free390.157-1~deb11u1vulnerable
sid/non-free390.157-7vulnerable
nvidia-graphics-drivers-tesla (PTS)bookworm/non-free-firmware525.147.05-4~deb12u1fixed
trixie/non-free-firmware, sid/non-free-firmware525.147.05-10fixed
nvidia-graphics-drivers-tesla-418 (PTS)bullseye/non-free418.226.00-6~deb11u1vulnerable
sid/non-free418.226.00-14vulnerable
nvidia-graphics-drivers-tesla-450 (PTS)bullseye/non-free450.248.02-1~deb11u1vulnerable
sid/non-free450.248.02-5fixed
nvidia-graphics-drivers-tesla-460 (PTS)bullseye/non-free460.106.00-6~deb11u1fixed
sid/non-free460.106.00-15fixed
nvidia-graphics-drivers-tesla-470 (PTS)bullseye/non-free470.223.02-2~deb11u1fixed
bookworm/non-free470.223.02-2~deb12u1fixed
trixie/non-free, sid/non-free470.239.06-1fixed
nvidia-open-gpu-kernel-modules (PTS)bookworm/contrib525.147.05-1~deb12u1fixed
trixie/contrib, sid/contrib535.161.08-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssourcebullseye470.223.02-1
nvidia-graphics-driverssourcebookworm525.147.05-1~deb12u1
nvidia-graphics-driverssource(unstable)525.147.05-11055136
nvidia-graphics-drivers-legacy-340xxsource(unstable)(unfixed)1055137
nvidia-graphics-drivers-legacy-390xxsource(unstable)(unfixed)1055138
nvidia-graphics-drivers-teslasourcebookworm525.147.05-3~deb12u1
nvidia-graphics-drivers-teslasource(unstable)525.147.05-11055143
nvidia-graphics-drivers-tesla-418source(unstable)(unfixed)1055139
nvidia-graphics-drivers-tesla-450source(unstable)450.248.02-41055140
nvidia-graphics-drivers-tesla-460source(unstable)460.106.00-31055141
nvidia-graphics-drivers-tesla-470sourcebullseye470.223.02-1~deb11u1
nvidia-graphics-drivers-tesla-470sourcebookworm470.223.02-1~deb12u1
nvidia-graphics-drivers-tesla-470source(unstable)470.223.02-11055142
nvidia-open-gpu-kernel-modulessourcebookworm525.147.05-1~deb12u1
nvidia-open-gpu-kernel-modulessource(unstable)525.147.05-11055144

Notes

[buster] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-460 <no-dsa> (Non-free not supported)
460.106.00-3 turned the package into a metapackage to aid switching to nvidia-graphics-drivers-tesla-470
450.248.02-4 turned the package into a metapackage to aid switching to nvidia-graphics-drivers-tesla-470
[bullseye] - nvidia-graphics-drivers-tesla-450 <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-418 <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-legacy-390xx <no-dsa> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-390xx <no-dsa> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-340xx <no-dsa> (Non-free not supported)
https://nvidia.custhelp.com/app/answers/detail/a_id/5491

Search for package or bug name: Reporting problems