CVE-2024-0078

NameCVE-2024-0078
DescriptionNVIDIA GPU Display Driver for Windows and Linux contains a vulnerability in the kernel mode layer, where a user in a guest can cause a NULL-pointer dereference in the host, which may lead to denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1064983, 1064984, 1064985, 1064986, 1064987, 1064988, 1064989, 1064990, 1064991

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)buster/non-free418.226.00-3vulnerable
bullseye/non-free470.223.02-1vulnerable
bookworm/non-free-firmware525.147.05-4~deb12u1vulnerable
trixie/non-free-firmware525.147.05-10vulnerable
sid/non-free-firmware535.161.08-1vulnerable
nvidia-graphics-drivers-legacy-340xx (PTS)buster/non-free340.108-3~deb10u1vulnerable
sid/non-free340.108-21vulnerable
nvidia-graphics-drivers-legacy-390xx (PTS)buster/non-free390.154-1~deb10u1vulnerable
buster/non-free (security)390.157-1~deb10u1vulnerable
bullseye/non-free390.157-1~deb11u1vulnerable
sid/non-free390.157-6vulnerable
nvidia-graphics-drivers-tesla (PTS)bookworm/non-free-firmware525.147.05-4~deb12u1vulnerable
trixie/non-free-firmware525.147.05-7vulnerable
sid/non-free-firmware525.147.05-10vulnerable
nvidia-graphics-drivers-tesla-418 (PTS)bullseye/non-free418.226.00-6~deb11u1vulnerable
sid/non-free418.226.00-13vulnerable
nvidia-graphics-drivers-tesla-450 (PTS)bullseye/non-free450.248.02-1~deb11u1vulnerable
sid/non-free450.248.02-4fixed
nvidia-graphics-drivers-tesla-460 (PTS)bullseye/non-free460.106.00-6~deb11u1fixed
sid/non-free460.106.00-14fixed
nvidia-graphics-drivers-tesla-470 (PTS)bullseye/non-free470.223.02-2~deb11u1vulnerable
bookworm/non-free470.223.02-2~deb12u1vulnerable
trixie/non-free, sid/non-free470.239.06-1fixed
nvidia-open-gpu-kernel-modules (PTS)bookworm/contrib525.147.05-1~deb12u1vulnerable
trixie/contrib525.147.05-3vulnerable
sid/contrib535.161.08-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssourceexperimental535.161.07-1
nvidia-graphics-driverssource(unstable)(unfixed)1064983
nvidia-graphics-drivers-legacy-340xxsource(unstable)(unfixed)1064984
nvidia-graphics-drivers-legacy-390xxsource(unstable)(unfixed)1064985
nvidia-graphics-drivers-teslasource(unstable)(unfixed)1064990
nvidia-graphics-drivers-tesla-418source(unstable)(unfixed)1064986
nvidia-graphics-drivers-tesla-450source(unstable)450.248.02-41064987
nvidia-graphics-drivers-tesla-460source(unstable)460.106.00-31064988
nvidia-graphics-drivers-tesla-470source(unstable)470.239.06-11064989
nvidia-open-gpu-kernel-modulessource(unstable)(unfixed)1064991

Notes

[bookworm] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-340xx <ignored> (Non-free not supported, no updates provided by Nvidia anymore)
[bullseye] - nvidia-graphics-drivers-legacy-390xx <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-418 <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-450 <no-dsa> (Non-free not supported)
450.248.02-4 turned the package into a metapackage to aid switching to nvidia-graphics-drivers-tesla-470
[bullseye] - nvidia-graphics-drivers-tesla-460 <no-dsa> (Non-free not supported)
460.106.00-3 turned the package into a metapackage to aid switching to nvidia-graphics-drivers-tesla-470
[bookworm] - nvidia-graphics-drivers-tesla-470 <no-dsa> (Non-free not supported)
[bullseye] - nvidia-graphics-drivers-tesla-470 <no-dsa> (Non-free not supported)
[bookworm] - nvidia-graphics-drivers-tesla <no-dsa> (Non-free not supported)
[bookworm] - nvidia-open-gpu-kernel-modules <no-dsa> (Contrib not supported)
https://nvidia.custhelp.com/app/answers/detail/a_id/5520

Search for package or bug name: Reporting problems